ثغرة خطيرة جدا ... يجب الحذر منها ...

استعرض الموضوع السابق استعرض الموضوع التالي اذهب الى الأسفل

ثغرة خطيرة جدا ... يجب الحذر منها ...

مُساهمة  لينكساوي في الأربعاء مايو 21, 2008 2:38 pm

السلام عليكم ،،،،


كل يوم نسمع بطرق واساليب جديدة للاختراق وسرقة المعلومات من غير اذن صاحبها ،،،
هذه المرة توجد ثغرة خطيرة تسمح - دون علمك - بسرقة معلوماتك وبيانتك المهمة ،،،،
وهي ليس تكمن في نظام تشغيل معين او برنامج معين به ثغرة او يحتاج الى انتي فايرس او جدار نار كل ذلك لن يقيك من تلك الثغرة ،،،

اريد ان اقدم شرحا وافيا - وان كان مملنا - لتلك العمليات :

تاريخ بسيط عن امن المعلومات :

كانت البيانات في الماضي ترسل ومعها معلومات مهمة جدا كاسم المستخدم وكلمة المرور وكل من اراد الحصول عليها فقط يعترضها في الطريق ، هذا كان قبل حلول التشفير ولكن بعد ابتكار التشفير ( البيانات تشفر قبل ارسالها ) لم تعد فيها منفعة للهاكر لانها مشفرة ولا يستطيع فك التشفير ، هو صحيح يستطيع الحصول وبكل سهولة على البيانات المرسلة لكنها غير مفيدة لانها مشفرة ، اذن في الحالتين قبل وبعد التشفير يستطيع الحصول على البياتات .

من خلال الاستنتاج السابق - الحصول على البيانات في كلا الحالتين - كانت هذه الثغرة الخطيرة ، وهي كما يلي :

في الحالة الاولى واضح سهلة جدا وانه بستطيع الحصول على البيانات الحساسة دون تعب او عناء - قبل التشفير - .
في الحالة الثانية - وهي المعنية هنا - يستطيع الحصول على البيانات الحساسة بطريقة اخرى - فك التشفير غير ممكن - وهو ما يسمى بالخداع او spoofing .

وهي كالتالي :
يقوم بنسخ البياتنات المرسلة المشفرة والتي تحتوي على اسم المستخدم وكلمة المرور - كالاي ميل مثلا - ومن ثم يقوم بخداع الجهة المرسلة اليها بانه هو المالك الحقيقي لهذه البيانات حيث كما علمنا فك التشفير غير ممكن .

واذا علمنا هذه المشكلة ما الطريق الى الوقاية منها :
الطريق هو استعمال اي بي الآمن IPsec بخلاف IP العادي الذي لا يصمد امام هذه الثغرة وهو كما يلي :

اما باستخدام IPv6 اي بي الاصدار السادس او بتنزيل الباكج الخاص بتريقة IPv4 الى IPsec ، حيث ان اي بي الاصدار الرابع لا يدعم IPsec الا بعد الترقية وتعريف الطريقة ( راجع طريقة عملها حسب نظام التشغيل المستخدم لديك ) حيث انني وجدتها فقط في رد هات redhat .

كيف يمكنني ان اتأكد في جهاز ما انها موجودة ام لا ؟؟

الحل هو : في اي شبكة انت تستخدمها سواء كانت في الجامعة او مقهى المهم اي شبكة اذا كانت تسخدم اي بي الاصدار الرابع IPv4 كما هو الغالب اسأل المسؤول هل يستخدم IPsec ام لا ؟؟ وفي حالة لا يستخدمه فكر بنفسك ؟؟؟

او الخيار الافضل هو استخدام شبكة من نوع اي بي الاصدار السادس IPv6 حيث انه يدعم IPsec بدون اية اضافات ، وان كان جديد وقلما تجد من يعرف تعريفه ، حيث تم اعتماده رسميا في امريكا واوربا - يعني ما في شبكة من الليلة وبعدها بتركب ليه شبكة من نوع IPv4 - .

ثغرة خطيرة حقا يجب الحظر منها وإلا لا نندم على ضياع معلومات حساسة .

لينكساوي
البرونزية
البرونزية

عدد الرسائل : 94
تاريخ التسجيل : 04/02/2008

معاينة صفحة البيانات الشخصي للعضو

الرجوع الى أعلى الصفحة اذهب الى الأسفل

استعرض الموضوع السابق استعرض الموضوع التالي الرجوع الى أعلى الصفحة


 
صلاحيات هذا المنتدى:
لاتستطيع الرد على المواضيع في هذا المنتدى